aboutsummaryrefslogtreecommitdiff
path: root/nix/tests/common.nix
diff options
context:
space:
mode:
authorSereja3132024-03-29 20:29:42 +0300
committerGitHub2024-03-29 20:29:42 +0300
commit2bad21828ee2c5d1e42588d5f4c53f5b10300c6a (patch)
treef22e488e7d057772809a9936ad124915ff968b6f /nix/tests/common.nix
parent0a0187794ac7f7a1e62cda3dabf8dc041f868790 (diff)
parenta92835264100583903dc408abe43d461ff7d4dca (diff)
Merge pull request #264 from serokell/sereja/OPS-1384-add-nixos-vm-test
[OPS-1384] Introduce NixOS VM tests
Diffstat (limited to 'nix/tests/common.nix')
-rw-r--r--nix/tests/common.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/nix/tests/common.nix b/nix/tests/common.nix
new file mode 100644
index 0000000..37abb5d
--- /dev/null
+++ b/nix/tests/common.nix
@@ -0,0 +1,21 @@
+# SPDX-FileCopyrightText: 2024 Serokell <https://serokell.io/>
+#
+# SPDX-License-Identifier: MPL-2.0
+
+{inputs, pkgs, ...}: {
+ nix = {
+ registry.nixpkgs.flake = inputs.nixpkgs;
+ extraOptions = ''
+ experimental-features = nix-command flakes
+ '';
+ settings = {
+ trusted-users = [ "root" "@wheel" ];
+ substituters = pkgs.lib.mkForce [];
+ };
+ };
+
+ virtualisation.graphics = false;
+ virtualisation.memorySize = 1536;
+ boot.loader.grub.enable = false;
+ documentation.enable = false;
+}