diff options
author | Alexander Bantyev | 2021-09-23 12:30:42 +0300 |
---|---|---|
committer | GitHub | 2021-09-23 12:30:42 +0300 |
commit | b8f42e2a7fb3e8fca268a8fb01e494c161e8a64e (patch) | |
tree | 7f5faa185f68a2f46a58d1de2248ae87d776b327 /flake.nix | |
parent | e5546f9c2503c26d175f08a81fc0a0f330be4cbe (diff) | |
parent | dc6e17b86f0026db86f6ec25c4df63ac497b9303 (diff) |
Merge pull request #128 from lovesegfault/no-naersk
flake: replace naersk with buildRustPackage
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 16 |
1 files changed, 8 insertions, 8 deletions
@@ -8,10 +8,6 @@ inputs = { nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable"; - naersk = { - url = "github:nmattia/naersk/master"; - inputs.nixpkgs.follows = "nixpkgs"; - }; utils.url = "github:numtide/flake-utils"; flake-compat = { url = "github:edolstra/flake-compat"; @@ -19,11 +15,10 @@ }; }; - outputs = { self, nixpkgs, utils, naersk, ... }: + outputs = { self, nixpkgs, utils, ... }: { overlay = final: prev: let - naersk-lib = final.callPackage naersk { }; system = final.system; isDarwin = final.lib.strings.hasSuffix "-darwin" system; darwinOptions = final.lib.optionalAttrs isDarwin { @@ -35,8 +30,13 @@ { deploy-rs = { - deploy-rs = naersk-lib.buildPackage (darwinOptions // { - root = ./.; + deploy-rs = final.rustPlatform.buildRustPackage (darwinOptions // { + pname = "deploy-rs"; + version = "0.1.0"; + + src = ./.; + + cargoLock.lockFile = ./Cargo.lock; }) // { meta.description = "A Simple multi-profile Nix-flake deploy tool"; }; lib = rec { |