aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authornotgne22021-01-24 18:53:42 -0700
committernotgne22021-01-24 18:53:42 -0700
commitb35fccfd67945d029906c217a6302928e849a3eb (patch)
treebbc503f06540f8ee953cd0a1f0b44c11f3722a68 /flake.nix
parentfc77473568cfcb86245c4cf45b59d7b86e049a5c (diff)
parenta33127ad4144282696b061af61c188e75ee49452 (diff)
Merge branch 'master' into notgne2/document-hostname-dot
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix11
1 files changed, 10 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 4513495..545762f 100644
--- a/flake.nix
+++ b/flake.nix
@@ -63,6 +63,8 @@
name = base.name + "-activate-path";
text = ''
#!${pkgs.runtimeShell}
+ set -euo pipefail
+
${activate}
'';
executable = true;
@@ -80,7 +82,14 @@
];
};
- nixos = base: custom base.config.system.build.toplevel "$PROFILE/bin/switch-to-configuration switch";
+ nixos = base: custom base.config.system.build.toplevel ''
+ $PROFILE/bin/switch-to-configuration switch
+
+ # https://github.com/serokell/deploy-rs/issues/31
+ ${with base.config.boot.loader;
+ pkgs.lib.optionalString systemd-boot.enable
+ "sed -i '/^default /d' ${efi.efiSysMountPoint}/loader/loader.conf"}
+ '';
noop = base: custom base ":";
};