aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorAlexander Bantyev2021-08-04 12:09:54 +0300
committerGitHub2021-08-04 12:09:54 +0300
commit2d06590cb0ea6a6e0f54866661cc5e665433bc71 (patch)
tree805a20aa25b93cc8b5d81387287d6d2eb4e2d5de /flake.nix
parentcfa203b1d344bb68b995a15a8adeb4f23da09ab5 (diff)
parenta0dd40684d292203b751f6e49c369503f83d1c2a (diff)
Merge branch 'master' into as-lib
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix12
1 files changed, 11 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 40f0724..03f4a25 100644
--- a/flake.nix
+++ b/flake.nix
@@ -143,7 +143,17 @@
devShell = pkgs.mkShell {
inputsFrom = [ self.packages.${system}.deploy-rs ];
- buildInputs = [ pkgs.nixUnstable pkgs.rust-analyzer pkgs.rustfmt ];
+ RUST_SRC_PATH = "${pkgs.rust.packages.stable.rustPlatform.rustLibSrc}";
+ buildInputs = with pkgs; [
+ nixUnstable
+ cargo
+ rustc
+ rust-analyzer
+ rustfmt
+ clippy
+ reuse
+ rust.packages.stable.rustPlatform.rustLibSrc
+ ];
};
checks = {