diff options
author | Andreas Fuchs | 2020-11-25 19:00:01 -0500 |
---|---|---|
committer | notgne2 | 2020-12-02 10:24:23 -0700 |
commit | 6ccc0b7ae981d8cd872af1eae69a2435aa87b8ef (patch) | |
tree | 53fe082c914ec12a165e552e3934ad7309b7f3a6 /flake.nix | |
parent | fa4c0a86cd608f5e98b50e8eb4b03db04a7726ce (diff) |
Write an "activate-rs" script into the profile path
This should point to the correct path if the target platform differs
fro the deploying platform.
Diffstat (limited to '')
-rw-r--r-- | flake.nix | 9 |
1 files changed, 9 insertions, 0 deletions
@@ -69,6 +69,15 @@ executable = true; destination = "/deploy-rs-activate"; }) + (pkgs.writeTextFile { + name = base.name + "-activate-rs"; + text = '' + #!${pkgs.runtimeShell} + exec ${self.defaultPackage."${system}"}/bin/activate "$@" + ''; + executable = true; + destination = "/activate-rs"; + }) ]; }; |