diff options
author | Sergey Gulin | 2024-04-01 14:52:41 +0300 |
---|---|---|
committer | Sergey Gulin | 2024-04-01 15:02:55 +0300 |
commit | f10a3aa17c9cbb1d217ab03369909af6fc29e1d0 (patch) | |
tree | 86535df8eb617e1bbdf5ab712590ef32e8c74993 /flake.nix | |
parent | 2bad21828ee2c5d1e42588d5f4c53f5b10300c6a (diff) |
[Chore] Fix overlay
Problem: In my recent PR(#264), I accidentally picked overlay output
changes from the philtaken/nixos-vm-tests branch, which broke existing
overlay imports after updating the deploy-rs input.
Solution: Add backwards compatibility so that users don't have to make
changes to their nix flakes.
Diffstat (limited to '')
-rw-r--r-- | flake.nix | 5 |
1 files changed, 3 insertions, 2 deletions
@@ -16,8 +16,8 @@ }; outputs = { self, nixpkgs, utils, ... }@inputs: - { - overlays.default = final: prev: let + rec { + overlay = final: prev: let system = final.stdenv.hostPlatform.system; darwinOptions = final.lib.optionalAttrs final.stdenv.isDarwin { buildInputs = with final.darwin.apple_sdk.frameworks; [ @@ -147,6 +147,7 @@ }; }; }; + overlays.default = overlay; } // utils.lib.eachSystem (utils.lib.defaultSystems ++ ["aarch64-darwin"]) (system: let |