aboutsummaryrefslogtreecommitdiff
path: root/examples/system/hello.nix
diff options
context:
space:
mode:
authornotgne22020-09-29 21:27:52 -0700
committernotgne22020-09-29 21:27:52 -0700
commit05a997558400f093c7278decd6300ce09044227b (patch)
tree9600f882d720a9d00de7c28fad6993d2b5fc5007 /examples/system/hello.nix
parenta0328dbcf76b7c551e92fd25060cfc7d7e4d9ebe (diff)
parent8d21dd335e5259dadf832a5d1a7c72b9dd1f4400 (diff)
Merge branch 'master' of github.com:notgne2/deploy-rs into master
Diffstat (limited to '')
-rw-r--r--examples/system/hello.nix9
1 files changed, 6 insertions, 3 deletions
diff --git a/examples/system/hello.nix b/examples/system/hello.nix
index 8c207f1..df57308 100644
--- a/examples/system/hello.nix
+++ b/examples/system/hello.nix
@@ -1,3 +1,7 @@
+# SPDX-FileCopyrightText: 2020 Serokell <https://serokell.io/>
+#
+# SPDX-License-Identifier: MPL-2.0
+
nixpkgs:
let
pkgs = nixpkgs.legacyPackages.x86_64-linux;
@@ -14,11 +18,10 @@ let
text = mkService "hello" {
unitConfig.WantedBy = [ "multi-user.target" ];
path = [ pkgs.hello ];
- script = "hello -g lel; touch $HOME/oof";
+ script = "hello";
};
};
-in
-pkgs.writeShellScriptBin "activate" ''
+in pkgs.writeShellScriptBin "activate" ''
mkdir -p $HOME/.config/systemd/user
rm $HOME/.config/systemd/user/hello.service
ln -s ${service} $HOME/.config/systemd/user/hello.service