aboutsummaryrefslogtreecommitdiff
path: root/examples/simple/flake.nix
diff options
context:
space:
mode:
authornotgne22020-10-05 19:53:59 -0700
committernotgne22020-10-05 19:53:59 -0700
commit58a934b997bb06f475bf707d0994f1fa37584cc1 (patch)
treef725edcc958a35a6e973bab390a67305417a810e /examples/simple/flake.nix
parent7c00fd2761e6efffe763ece5d08d9a6d3fb95092 (diff)
Clean up `simple` example
Diffstat (limited to '')
-rw-r--r--examples/simple/flake.nix37
1 files changed, 9 insertions, 28 deletions
diff --git a/examples/simple/flake.nix b/examples/simple/flake.nix
index d44b888..a8ad0f7 100644
--- a/examples/simple/flake.nix
+++ b/examples/simple/flake.nix
@@ -7,34 +7,15 @@
inputs.deploy-rs.url = "github:serokell/deploy-rs";
- outputs = { self, nixpkgs, deploy-rs }:
- let
- setActivate = base: activate: nixpkgs.legacyPackages.x86_64-linux.symlinkJoin {
- name = ("activatable-" + base.name);
- paths = [
- base
- (nixpkgs.legacyPackages.x86_64-linux.writeTextFile {
- name = base.name + "-activate-path";
- text = ''
- #!${nixpkgs.legacyPackages.x86_64-linux.runtimeShell}
- ${activate}
- '';
- executable = true;
- destination = "/activate";
- })
- ];
+ outputs = { self, nixpkgs, deploy-rs }: {
+ deploy.nodes.example = {
+ hostname = "localhost";
+ profiles.hello = {
+ user = "balsoft";
+ path = deploy-rs.lib.x86_64-linux.setActivate nixpkgs.legacyPackages.x86_64-linux.hello "./bin/hello";
};
- in
- {
-
- deploy.nodes.example = {
- hostname = "localhost";
- profiles.hello = {
- user = "balsoft";
- path = deploy-rs.lib.x86_64-linux.setActivate nixpkgs.legacyPackages.x86_64-linux.hello "./bin/hello";
- };
- };
-
- checks = { "x86_64-linux" = { jsonSchema = deploy-rs.lib.x86_64-linux.checkSchema self.deploy; }; };
};
+
+ checks = { "x86_64-linux" = { jsonSchema = deploy-rs.lib.x86_64-linux.checkSchema self.deploy; }; };
+ };
}