aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authornotgne22020-10-10 10:31:58 -0700
committernotgne22020-10-10 10:31:58 -0700
commit4a2b677e892845b121d353864d54aec92a411e48 (patch)
tree39de25748b17ee9d2236a74e297b9bd7c33f6e28 /default.nix
parentdb8301a45796cd919cbfa085f85ac6288e73a8db (diff)
parent219d55e99e792a093c12dbc045bed88a4bfe1916 (diff)
Merge branch 'master' of github.com:notgne2/deploy-rs into master
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..873ece4
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,13 @@
+(import
+ (
+ let
+ lock = builtins.fromJSON (builtins.readFile ./flake.lock);
+ in
+ fetchTarball {
+ url = "https://github.com/edolstra/flake-compat/archive/${lock.nodes.flake-compat.locked.rev}.tar.gz";
+ sha256 = lock.nodes.flake-compat.locked.narHash;
+ }
+ )
+ {
+ src = ./.;
+ }).defaultNix