aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authornotgne22021-02-09 03:00:48 -0700
committernotgne22021-02-09 03:00:48 -0700
commitc27b76e00101a1190c46c80fc1618c2732827d96 (patch)
tree6e1de8e143b1565d60798549ab235fe7d9993ccc /Cargo.toml
parent64f84aaf87b8771cd8050d932c96400df9ccd75b (diff)
parent4f956e0979d6e2617a0800062627a345337bff71 (diff)
Merge branch 'master' into notgne2/set-tmp-in-nixos-activation
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml23
1 files changed, 11 insertions, 12 deletions
diff --git a/Cargo.toml b/Cargo.toml
index dc239e5..fce88bd 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,22 +12,21 @@ edition = "2018"
[dependencies]
clap = "3.0.0-beta.2"
-tokio = { version = "0.3.5", features = [ "full" ] }
-serde_json = "1.0.48"
-serde_derive = "1.0.104"
-serde = "1.0.104"
-merge = "0.1.0"
-whoami = "0.9.0"
-log = "0.4"
flexi_logger = "0.16"
-notify = "5.0.0-pre.3"
-futures-util = "0.3.6"
fork = "0.1"
+futures-util = "0.3.6"
+log = "0.4"
+merge = "0.1.0"
+notify = "5.0.0-pre.3"
+rnix = "0.8"
+serde = { version = "1.0.104", features = [ "derive" ] }
+serde_json = "1.0.48"
+signal-hook = "0.3"
thiserror = "1.0"
+tokio = { version = "0.3.5", features = [ "full" ] }
toml = "0.5"
+whoami = "0.9.0"
yn = "0.1"
-rnix = "0.8"
-signal-hook = "0.3"
# smol_str is required by rnix, but 0.1.17 doesn't build on rustc
# 1.45.2 (shipped in nixos-20.09); it requires rustc 1.46.0. See
@@ -37,4 +36,4 @@ smol_str = "=0.1.16"
[lib]
name = "deploy"
-path = "src/lib.rs" \ No newline at end of file
+path = "src/lib.rs"