aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authornotgne22021-02-08 23:47:32 -0700
committerGitHub2021-02-08 23:47:32 -0700
commit96a268db2dceb6b6c63d3fa2d47e2c188a1b11f4 (patch)
treecd58b4f6436bda62b08fd6ee266850f28d32769c /Cargo.toml
parent4f4c1e3cf7c9bc13a1dfd7d0035696cf6e7eaeb6 (diff)
parent8571c086c591cd154f3b23b5c552c1b87bf1975d (diff)
Merge pull request #47 from lovesegfault/style-fixes
changed: assorted fixes
Diffstat (limited to '')
-rw-r--r--Cargo.toml23
1 files changed, 11 insertions, 12 deletions
diff --git a/Cargo.toml b/Cargo.toml
index dc239e5..fce88bd 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,22 +12,21 @@ edition = "2018"
[dependencies]
clap = "3.0.0-beta.2"
-tokio = { version = "0.3.5", features = [ "full" ] }
-serde_json = "1.0.48"
-serde_derive = "1.0.104"
-serde = "1.0.104"
-merge = "0.1.0"
-whoami = "0.9.0"
-log = "0.4"
flexi_logger = "0.16"
-notify = "5.0.0-pre.3"
-futures-util = "0.3.6"
fork = "0.1"
+futures-util = "0.3.6"
+log = "0.4"
+merge = "0.1.0"
+notify = "5.0.0-pre.3"
+rnix = "0.8"
+serde = { version = "1.0.104", features = [ "derive" ] }
+serde_json = "1.0.48"
+signal-hook = "0.3"
thiserror = "1.0"
+tokio = { version = "0.3.5", features = [ "full" ] }
toml = "0.5"
+whoami = "0.9.0"
yn = "0.1"
-rnix = "0.8"
-signal-hook = "0.3"
# smol_str is required by rnix, but 0.1.17 doesn't build on rustc
# 1.45.2 (shipped in nixos-20.09); it requires rustc 1.46.0. See
@@ -37,4 +36,4 @@ smol_str = "=0.1.16"
[lib]
name = "deploy"
-path = "src/lib.rs" \ No newline at end of file
+path = "src/lib.rs"