summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix12
1 files changed, 5 insertions, 7 deletions
diff --git a/flake.nix b/flake.nix
index b638d4ee..a436d773 100644
--- a/flake.nix
+++ b/flake.nix
@@ -8,11 +8,12 @@
flake-utils.follows = "charon/flake-utils";
nixpkgs.follows = "charon/nixpkgs";
hacl-nix.url = "github:hacl-star/hacl-nix";
+ flake-compat.url = "github:nix-community/flake-compat";
};
# Remark: keep the list of outputs in sync with the list of inputs above
# (see above remark)
- outputs = { self, charon, flake-utils, nixpkgs, hacl-nix }:
+ outputs = { self, charon, flake-utils, nixpkgs, hacl-nix, flake-compat }:
flake-utils.lib.eachSystem [ "x86_64-linux" ] (system:
let
pkgs = import nixpkgs { inherit system; };
@@ -81,8 +82,9 @@
# the files which are checked out (we have to be careful about
# files like lakefile.lean, and the user hand-written files)
- # Run the tests - remark: we could remove the file
- make test-all -j $NIX_BUILD_CORES
+ # Run the tests with extra sanity checks enabled
+ # Remark: we could remove the file
+ OPTIONS=-checks make test-all -j $NIX_BUILD_CORES
# Check that there are no differences between the generated tests
# and the original tests
@@ -153,10 +155,6 @@
default = aeneas;
};
devShells.default = pkgs.mkShell {
- # By default, tests run some sanity checks which are pretty slow.
- # This disables these checks when developping locally.
- OPTIONS = "";
-
packages = [
pkgs.ocamlPackages.ocaml
pkgs.ocamlPackages.ocamlformat