summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorNadrieril2024-05-22 15:11:28 +0200
committerGuillaume Boisseau2024-05-24 14:24:38 +0200
commit6f14e8c699169aa11ea9c106f8cae1ba593569d0 (patch)
tree35e539becc5a8c6642eb3c37a851b25c0ccdffa1 /flake.nix
parentad819ad9ccdf137ca87eb367810694246696b835 (diff)
Add simple test runner
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix15
1 files changed, 12 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index d380170a..7dd2b7c0 100644
--- a/flake.nix
+++ b/flake.nix
@@ -47,6 +47,7 @@
'';
installPhase = "touch $out";
};
+
aeneas = ocamlPackages.buildDunePackage {
pname = "aeneas";
version = "0.1.0";
@@ -70,6 +71,15 @@
echo charon.packages.${system}.tests
'';
};
+
+ test_runner = ocamlPackages.buildDunePackage {
+ pname = "aeneas_test_runner";
+ version = "0.1.0";
+ duneVersion = "3";
+ src = ./tests/test_runner;
+ OCAMLPARAM = "_,warn-error=+A"; # Turn all warnings into errors.
+ };
+
# Run the translation on various files.
# Make sure we don't need to recompile the package whenever we make
# unnecessary changes - we list the exact files and folders the package
@@ -88,9 +98,8 @@
# We need to provide the paths to the Charon tests derivations
export CHARON_TEST_DIR=${charon.checks.${system}.tests}
- # Copy the Aeneas executable, and update the path to it
- cp ${aeneas}/bin/aeneas aeneas
- export AENEAS_EXE=./aeneas
+ export AENEAS_EXE=${aeneas}/bin/aeneas
+ export TEST_RUNNER_EXE=${test_runner}/bin/test_runner
# Copy the tests
cp -r tests tests-copy