summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorZack Grannan2024-04-24 17:26:21 -0700
committerZack Grannan2024-04-26 12:52:02 -0700
commit281513027f3a4c5650109d725d1ac5ee7739edba (patch)
treea35feb03710a3f20e53544ef93ac5ba1b37461fc /flake.nix
parent5da597289c1723aa59bf87ad5075675820c18f73 (diff)
Use eachDefaultSystem in flake.nix, update charon in flake.lock
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 7faee70a..6f868e3b 100644
--- a/flake.nix
+++ b/flake.nix
@@ -14,7 +14,7 @@
# Remark: keep the list of outputs in sync with the list of inputs above
# (see above remark)
outputs = { self, charon, flake-utils, nixpkgs, hacl-nix, flake-compat }:
- flake-utils.lib.eachSystem [ "x86_64-linux" ] (system:
+ flake-utils.lib.eachDefaultSystem (system:
let
pkgs = import nixpkgs { inherit system; };
ocamlPackages = pkgs.ocamlPackages;