summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorSon Ho2023-03-08 00:46:24 +0100
committerSon HO2023-06-04 21:44:33 +0200
commitd0ca6d46d3de989c4e9c3cd9b6678d18777ec263 (patch)
treefd7f89edd3e83d50d885fbb1dfb1f36bb7966eae /flake.nix
parentf2ea90c5a9e4a50f90448dea71ee2489029501c5 (diff)
Make a minor modification to flake.nix
Diffstat (limited to '')
-rw-r--r--flake.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index bf0c19d7..8fb20372 100644
--- a/flake.nix
+++ b/flake.nix
@@ -84,7 +84,7 @@
export AENEAS_EXE=./aeneas.exe
# Run the tests
- make tests -j
+ make tests -j $NIX_BUILD_CORES
'';
# Tests don't generate anything new as the generated files are
# versionned, but the installation phase still needs to prodocue
@@ -98,7 +98,7 @@
FSTAR_EXE = "${hacl-nix.packages.${system}.fstar}/bin/fstar.exe";
buildPhase= ''
make prepare-projects
- make verify -j
+ make verify -j $NIX_BUILD_CORES
'';
# The tests don't generate anything
installPhase = "touch $out";
@@ -110,7 +110,7 @@
buildInputs = [ pkgs.coq ];
buildPhase= ''
make prepare-projects
- make verify -j
+ make verify -j $NIX_BUILD_CORES
'';
# The tests don't generate anything
installPhase = "touch $out";