summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorSon Ho2024-04-25 08:21:43 +0200
committerSon Ho2024-04-25 08:21:43 +0200
commit51214e534e26d473b9260befc967cfd287bb9eb3 (patch)
treeeb09a3852be8f20f14943b9fe52223f3b02ca330 /default.nix
parent5f2a388d1ff039cde0d78daaba58c191b404405e (diff)
parent1be37966ceea2510b911b119a96246b4657a62fd (diff)
Merge branch 'main' into option-take
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 00000000..d7da8cd1
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,16 @@
+# This file provides backward compatibility to nix < 2.4 clients
+{ system ? builtins.currentSystem }:
+let
+ lock = builtins.fromJSON (builtins.readFile ./flake.lock);
+
+ inherit (lock.nodes.flake-compat.locked) owner repo rev narHash;
+
+ flake-compat = fetchTarball {
+ url = "https://github.com/${owner}/${repo}/archive/${rev}.tar.gz";
+ sha256 = narHash;
+ };
+
+ flake = import flake-compat { inherit system; src = ./.; };
+in
+flake.defaultNix
+