rec {
  tags = tags: url: {
    tags = tags;
    inherit url;
  };
  btag = url: t: tags [ t "blog" ] url;
  btags = url: ts: tags (ts ++ [ "blog" ]) url;

  ntag = url: t: tags [ t "news" ] url;
  jtag = url: t: tags [ t "journal" ] url;

  vtag = url: t: tags [ t "video" ] url;
  ytag = channel: tag: vtag ("https://www.youtube.com/feeds/videos.xml?channel_id=${channel}") tag;
  blender = channel: vtag "https://video.blender.org/feeds/videos.xml?videoChannelId=${toString channel}" "blender";

  podcast = url: tags [ "podcast" ] url;
  music = url: tags [ "music" ] url;

  fr = "français";
}