{ config, lib, pkgs, ... }:

{
  services.grafana = {
    enable = true;
    domain = "localhost";
    port = 4000;
  };

  services.prometheus = {
    enable = true;
    port = 9001;
    scrapeConfigs = [
      {
        job_name = "tracktrain";
        static_configs = [ {
          targets = [ "127.0.0.1:8080" ];
        } ];
      }
    ];
  };
}