{ config, lib, pkgs, inputs, ... }:

let
  #sources = ../../nix/sources.nix;
  sources = /home/stuebinm/Dokumente/utils/playground/ilztal/server;
in
{
  # systemd.services.woitb = {
  #   enable = true;
  #   description = "wo ist die ilztalbahn?";
  #   wantedBy = [ "multi-user.target" ];
  #   serviceConfig.type = "simple";
  #   script = "${import sources}/bin/woitb";
  # };

  services.nginx.enable = true;
  services.nginx.virtualHosts."ilztal.live" = {
    enableACME = true;
    forceSSL = true;
    locations."/".root = pkgs.copyPathToStore ./woitb;

    # locations."/upnext".proxyPass = "http://localhost:8000";
    # locations."/geoloc".proxyPass = "http://localhost:8000";
  };

  services.nginx.virtualHosts."track.ilztal.live" = {
    enableACME = true;
    forceSSL = true;
    locations."/".root = inputs.tracktrain;
  };

}