{ config, lib, pkgs, ... }:

{
  services.nfs.server = {
    enable = true;
    # hostName = "abbenay";

    exports = ''
      /export 192.168.69.104(rw,sync,fsid=0,no_subtree_check)
      /export/shared 192.168.69.104(rw,sync,insecure,nohide,no_subtree_check)
    '';
  };

  fileSystems."/export/shared" = {
    device = "/home/stuebinm/shared";
    options = [ "bind" ];
  };

  networking.firewall.allowedTCPPorts = [ 2049 ];
}