aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--Cargo.toml11
1 files changed, 4 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 335dcc8..dc239e5 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -19,7 +19,7 @@ serde = "1.0.104"
merge = "0.1.0"
whoami = "0.9.0"
log = "0.4"
-pretty_env_logger = "0.4"
+flexi_logger = "0.16"
notify = "5.0.0-pre.3"
futures-util = "0.3.6"
fork = "0.1"
@@ -27,6 +27,7 @@ thiserror = "1.0"
toml = "0.5"
yn = "0.1"
rnix = "0.8"
+signal-hook = "0.3"
# smol_str is required by rnix, but 0.1.17 doesn't build on rustc
# 1.45.2 (shipped in nixos-20.09); it requires rustc 1.46.0. See
@@ -34,10 +35,6 @@ rnix = "0.8"
smol_str = "=0.1.16"
-[[bin]]
+[lib]
name = "deploy"
-path = "src/main.rs"
-
-[[bin]]
-name = "activate"
-path = "src/activate.rs" \ No newline at end of file
+path = "src/lib.rs" \ No newline at end of file